HOMEPAGE FORUMS NEWS DOCUMENTATION SCREENSHOTS
SystemRescueCd forums
View unanswered posts | View active topics It is currently 21 Aug 2014, 21:58



Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
 Sysres USB ask for CD during boot. 
Author Message

Joined: 21 Jan 2008, 14:37
Posts: 9
Post Sysres USB ask for CD during boot.
Hi,

I followed the procedure to use sysres on a USB stick. After the BIOS routine checks, there is the sysres prompt (isolinux) i press enter, the kernel boots, the system loads kernel's modules and then it tries to mount the CDROM ! as the CD tray is empty, the system hangs indefinitely. If i put the sysres CD in the tray the system continues booting and finally arrives to the shell's prompt.

Is there any boots option to avoid this or something ? I prefer asking you people before looking at the inits scripts.

Thanks in advance,
Greg

PS:

The weird thing is that the CD i put in the tray is actually not mounted on the system.
Code:
# mount
tmpfs on / type tmpfs (rw)
/dev/sdc1 on /mnt/cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,utf8)
/dev/loop0 on /mnt/livecd type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec)
tmpfs on /mnt/livecd/lib/firmware type tmpfs (rw)
tmpfs on /mnt/livecd/usr/portage type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
nfsd on /proc/fs/nfs type nfsd (rw,noexec,nosuid,nodev)



21 Jan 2008, 14:57
Profile
Site Admin

Joined: 17 Jul 2003, 09:44
Posts: 2700
Post 
Check the location of the files in your usb stick. They must not be in the isolinux directory. All files must be in the root of your fat filesystem. Also check that you did not rename sysrcd.dat.

The scripts says CDRom, because the USB-stick is considered as a CD when you boot from the usb.


21 Jan 2008, 20:24
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
I'll check the isolinux files,
cheers,
Greg


22 Jan 2008, 09:11
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
It still asks for the CD, the isolinux files and in the root of the usb stick :(

it writes attempting to mount /dev/sr0


Cheers,
Greg


23 Jan 2008, 17:42
Profile
Site Admin

Joined: 17 Jul 2003, 09:44
Posts: 2700
Post 
When it fails and you get the minimal shell, what files are in /mnt/cdrom ?

Can you use 'dmesg' to see which device is /dev/sdc1 ?


23 Jan 2008, 22:16
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
There is not failure, actually i can put any CD on the drive it is just fine, looks like it just want to mount something. I just realized that if if i wait quite a long time, the systems continues to boot normally. Is there any kernel boot option to skip this long delay (directly specify the right device) ?

Cheers,
Greg

PS: My usb partition is /dev/sdc (not sdc1), when the system is finally up /dev/sdc is mounted on /mnt/cdrom


24 Jan 2008, 09:10
Profile
Site Admin

Joined: 17 Jul 2003, 09:44
Posts: 2700
Post 
Yes there is an option 'scandelay' that is set to 10 seconds by default in syslinux.cfg for usb keys. Some time is necessary for usb device to initialize. If you try to load the usb device immediately after the driver was loaded, it would fail.

You can try to decrease the scandelay anyway... Just edit syslinux.cfg and replace all the scandelay=10 with scandelay=2 for instance.


24 Jan 2008, 12:38
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
It doesn't work , it still looks for the CD for ages, the CDROM led is blanking.

>>> Attempting to mount /dev/sr0

My key is prepared this way :
mkfs.vfat -F 16 -n USB /dev/sdb -I
syslinux /dev/sda


24 Jan 2008, 14:49
Profile
Site Admin

Joined: 17 Jul 2003, 09:44
Posts: 2700
Post 
Check you used the same device name (you say both /dev/sda and /dev/sdb there)

You can also use option -ma (under windows) with syslinux as said in the handbook


24 Jan 2008, 20:14
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
Yes i said sdb but it was a typing error.

Maybe the problem comes from this:

if i do :

Code:
mkfs.vfat -F 16  /dev/sda -I (pay attention, it uses "-I" here)
syslinux /dev/sda (pay attention, it is "sda", not "sda1" here)


It works, the system boots, i just have the CD issue

But if i do like in the tutorial:

Code:
fdisk /dev/sda

Create primary partition, type WIN95.
Code:
mkfs.vfat -F 16 /dev/sda1 (pay attention, it is
"sda1", not "sda" here)
syslinux /dev/sda1 (pay attention, it is "sda1", not "sda" here)


It doesn't work there is no syslinux boot prompt...

Maybe the problem comes from this...

Greg


28 Jan 2008, 09:22
Profile
Site Admin

Joined: 17 Jul 2003, 09:44
Posts: 2700
Post 
Yes the partitionning of the usb key really matters. There are instructions about it in this how-to:
http://www.sysresccd.org/Howto_install-usb-stick


28 Jan 2008, 14:21
Profile

Joined: 21 Jan 2008, 14:37
Posts: 9
Post 
Conclusion:

BIOS bug.

Cheers mates,
Greg


28 Jan 2008, 16:47
Profile

Joined: 24 Mar 2008, 23:21
Posts: 2
Post 
dabui wrote:
Conclusion:

BIOS bug.

Interesting, I'm having the same issue here on a Gigabyte 965P-DS4 Rev2. When booting from my USB-stick (dev/sdb1) SysRescCD boots fine but it takes ages until "Attempting to mount media: /dev/sr0" times out :(

Now I don't know if this is due to a buggy BIOS, but is there any workaround or possibly a switch to leave the cdrom alone?


24 Mar 2008, 23:31
Profile

Joined: 26 Mar 2008, 09:00
Posts: 8
Post 
puntarenas wrote:
Interesting, I'm having the same issue here on a Gigabyte 965P-DS4 Rev2. When booting from my USB-stick (dev/sdb1) SysRescCD boots fine but it takes ages until "Attempting to mount media: /dev/sr0" times out :(

Now I don't know if this is due to a buggy BIOS, but is there any workaround or possibly a switch to leave the cdrom alone?


I've got the same problem here (MSI-P6N SLI). I don't think it has anything to do with the BIOS (not at this stage of the startup sequence). A workaround would be using the "skipmount=/dev/sr0" option, but it is only available in the current beta. When 1.0.1 is released, you could also make it a default option by adding it to "syslinux.cfg"...


26 Mar 2008, 09:16
Profile

Joined: 24 Mar 2008, 23:21
Posts: 2
Post 
MiniMe wrote:
A workaround would be using the "skipmount=/dev/sr0" option, but it is only available in the current beta.

I'm using 1.0.1 Beta7 on my stick, but unfortunately "skipmount=/dev/sr0" doesn't do anything.

If this is a BIOS bug, what should I ask my vendor to fix?


27 Mar 2008, 20:54
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.