HOMEPAGE FORUMS NEWS DOCUMENTATION SCREENSHOTS
SystemRescueCd forums
View unanswered posts | View active topics It is currently 26 Jul 2014, 07:05



Post new topic Reply to topic  [ 5 posts ] 
 Stop shutdown when using testdisk 
Author Message

Joined: 09 Dec 2008, 17:16
Posts: 8
Location: Vancouver
Post Stop shutdown when using testdisk
I am trying to fix a partition on my laptop using testdisk, but, when I ask for a deeper search, and leave the laptop because it takes so long, the screen goes black and I have to reboot.

I don't think this is an actual shutdown, but is there a way to add a screensaver or something to prevent this happening? The testdisk process takes about two hours because I have a big disk.

Thanks.


10 Dec 2010, 22:41
Profile WWW

Joined: 07 Apr 2010, 16:19
Posts: 940
Post Re: Stop shutdown when using testdisk
Some biossetup can disable powermanagement. This is the savest way.
Try bootoptions for noapm, noacpi and acpi=off.
xset -s off disables the screensaver, but i think its a powermanagement thing . xset -dpms disables Energy Star (DPMS) features.

Run testdisk from a textconsole if you have this problem with Xorg.

Gernot


11 Dec 2010, 09:03
Profile

Joined: 09 Dec 2008, 17:16
Posts: 8
Location: Vancouver
Post Re: Stop shutdown when using testdisk
gernot wrote:
Some biossetup can disable powermanagement. This is the savest way.
Try bootoptions for noapm, noacpi and acpi=off.
xset -s off disables the screensaver, but i think its a powermanagement thing . xset -dpms disables Energy Star (DPMS) features.

Run testdisk from a textconsole if you have this problem with Xorg.

Gernot


Ok, I have booted with options "docache backstore=alldev noapm noacpi acpi=off" and
am starting to try to recover my 500Gb disk. I'll report back w.r.t. screen blanking.
Thanks, -jae


12 Dec 2010, 20:59
Profile WWW

Joined: 09 Dec 2008, 17:16
Posts: 8
Location: Vancouver
Post Re: Stop shutdown when using testdisk
jae wrote:
gernot wrote:
Some biossetup can disable powermanagement. This is the savest way.
Try bootoptions for noapm, noacpi and acpi=off.
xset -s off disables the screensaver, but i think its a powermanagement thing . xset -dpms disables Energy Star (DPMS) features.

Run testdisk from a textconsole if you have this problem with Xorg.

Gernot


Ok, I have booted with options "docache backstore=alldev noapm noacpi acpi=off" and
am starting to try to recover my 500Gb disk. I'll report back w.r.t. screen blanking.
Thanks, -jae


Nope. Part way throught an unattended "deeper" testdisk search, screen went black and there was no response to keys or mouse. So what I need is a SCREENSAVER. I think. Does anyone know how to install a screensaver on a USB stick version of systermrescuecd??

Thanks.


12 Dec 2010, 22:53
Profile WWW

Joined: 07 Apr 2010, 16:19
Posts: 940
Post Re: Stop shutdown when using testdisk
In near sure a Screensaver dont solve the problem.
Try dont using X, and run on the textconsole
setterm -blank 0
setterm -powersave off
setterm -powerdown 0

I had a similar problem where only the disabling powersaving in the biossetup helped.

Booting with "nomodeset" as also worth a try.

Gernot


13 Dec 2010, 05:07
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.