HOMEPAGE FORUMS NEWS DOCUMENTATION SCREENSHOTS
SystemRescueCd forums
View unanswered posts | View active topics It is currently 30 Oct 2014, 14:23



Post new topic Reply to topic  [ 4 posts ] 
 Ext2 file system missing 
Author Message

Joined: 14 Jan 2011, 17:34
Posts: 2
Post Ext2 file system missing
Hi

Im wondering if i could use the sysrescuecd to restore the files ystem on a drive.Whithout formatting it
It was ext2 formatted, put it in a NAS that tried to format it.
I stopped it after maybe a second but seems like it was enough to ruin it

The drive now shows now "linux native" in all of the known partitioning program but says file system unknown
All my data is there i just dont know how to restore the file system
IS there any way i can achieve this using the sysrescue cd ?

Thank You !!


14 Jan 2011, 17:40
Profile

Joined: 07 Apr 2010, 16:19
Posts: 959
Post Re: Ext2 file system missing
First make a imagecopy of the partition just to be save.
ext2 hold some copys of the superblock.

With luck can start fsck with such an alternate superblock like desctibed in the appended sniplet of man fsck.ext2
--------
-b superblock
Instead of using the normal superblock, use an alternative superblock specified by superblock. This option is normally used when the primary superblock has been corrupted. The location of the backup superblock is dependent on the filesystem's blocksize. For filesystems with 1k blocksizes, a backup superblock can be found at block 8193; for filesystems with 2k blocksizes, at block 16384; and for 4k blocksizes, at block 32768.
Additional backup superblocks can be determined by using the
mke2fs program using the -n option to print out where the superblocks were created. The -b option to mke2fs, which specifies blocksize of the filesystem must be specified in order for the superblock locations that are printed out to be accurate.
If an alternative superblock is specified and
the filesystem is not opened read-only, e2fsck will make sure that the primary superblock is updated appropriately upon completion of the filesystem check.
------------


14 Jan 2011, 17:59
Profile

Joined: 14 Jan 2011, 17:34
Posts: 2
Post Re: Ext2 file system missing
Thank you
i think i tried everything and i guess i will have to kiss my data goodbye

Listed the backup superblocks, tried to mount the partition manually, no luck
Tried to run the fsck specifying the backup superblock, no go
Keep getting "bad magic number" error
Debugfs cannot mount the filesystem for the same reasons

Thank you for the advice


16 Jan 2011, 18:53
Profile

Joined: 07 Apr 2010, 16:19
Posts: 959
Post Re: Ext2 file system missing
tried you also superblocks at the partitions end?
A chance to recover some files (not the names of them) is photorec

gernot


16 Jan 2011, 19:42
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.